WordPress 5.5 заблокирует обновление мошеннических плагинов?

CMS WordPress 5.5 заблокирует автоматическое обновление скомпрометированных плагинов. По мнению команды разработчиков это необходимо для того, чтобы подобные плагины не смогли навредить сайтам.

Новый функционал будет автоматически проверять, является ли тот или иной плагин легитимным, и блокировать его обновление, в том случае если будет обнаружено подозрительное поведение.

Данный функционал был успешно реализован в числе более чем 450 разнообразных обновлений, внедренных в работу новейшей версии CMS WordPress 5.5 «Eckstine». Примечательно, что вплоть до нынешнего момента он никак не анонсировался.

По мнению независимых экспертов в области кибербезопасности блокировка автоматического обновления вредоносных плагинов является действительно необходимым и важным дополнением.

К сожалению, на сегодняшний день существует такая практика, как покупка WordPress- плагинов с целью добавления в них maladvertising и вредоносных ссылок.

Именно при помощи скомпрометированных плагинов на WordPress-сайты зачастую осуществляются хакерские атаки, например, такого типа, как «supply chain attack» (атака на цепочку поставок).

Полностью автоматизированная проверка и блокировка обновлений явно скомпрометированных плагинов позволит обезопасить WordPress-сайты.

В заключение стоит напомнить о том, среди ключевых обновлений, успешно реализованных в WordPress 5.5 «Eckstine» необходимо отметить lazy-loading, используемую по умолчанию, автоматическое обновление используемых плагинов и тем оформления, а также встроенные файлы Sitemap.

Меню